Critical

CVE-2002-1645 - Unspecified vulnerability in Ssh2

Publication: 2002-11-25
Summary

Buffer overflow in the URL catcher feature for SSH Secure Shell for Workstations client 3.1 to 3.2.0 allows remote attackers to execute arbitrary code via a long URL.

Risk level (CVSS 10)

Critical

10.0

Access Vector

  • Network
  • Adjacent Network
  • Local

Access Complexity

  • Low
  • Medium
  • High

Authentication

  • None
  • Single
  • Multiple

Confident. Impact

  • Complete
  • Partial
  • None

Integrity Impact

  • Complete
  • Partial
  • None

Affected Products

  • SSH Ssh2 3.1
  • SSH Ssh2 3.1.1
  • SSH Ssh2 3.1.2
  • SSH Ssh2 3.1.3
  • SSH Ssh2 3.1.4
  • SSH Ssh2 3.2