Latest Vulnerabilities Affecting 4Xem products