Latest Vulnerabilities Affecting 2Glux products